diff options
author | Rory Dudley | 2024-12-12 17:59:32 -0700 |
---|---|---|
committer | Rory Dudley | 2024-12-12 18:05:00 -0700 |
commit | fa9ec0c377305126f4c810be198bdca68d71a275 (patch) | |
tree | bdcd76287cf46384762454aad4ae841ac7a2539b /Cargo.toml | |
parent | 07e75b3f63001ca509df8d5b5a33336ab994814f (diff) | |
download | dwarvish-fa9ec0c377305126f4c810be198bdca68d71a275.tar.gz |
Rewrite of the buffer code + proper UTF-8 support
This patch rewrites much of the code in src/buffer.rs to (utlimately),
be less buggy. It also changed getchar() to have proper support for
UTF-8 characters. The autocomplete function was also enhanced to support
completions with filenames that have spaces in their paths. It handles
these by placing a backslash ('\') before each space in the filename.
There is not yet any completion support with quote ('), nor double-quote
characters ("). The buffer is still navigable with arrow keys, so
arbitrary deletions and insertions are still possible. Deletions and
insertions with multi-width UTF-8 characters work as expected.
Signed-off-by: Rory Dudley <rory@netc.lu>
Notes
Notes:
The complection function only works if the cursor is at the end of the
buffer. Pressing tab anywhere else will result in functionally a no op.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 1 |
1 files changed, 1 insertions, 0 deletions
@@ -17,3 +17,4 @@ libc = "0.2.153" nix = { version = "0.29.0", features = ["signal"] } signal-hook = "0.3.17" termios = "0.3.3" +unicode-width = "0.2.0" |