summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRory Dudley2024-02-16 19:21:58 -0700
committerRory Dudley2024-02-16 19:21:58 -0700
commit508550c4d5c1b8933decfb47fc02481959ab0c65 (patch)
treeec83275b7c303fa1fbe5e30feae77981836af2b8 /Cargo.toml
downloaddwarvish-508550c4d5c1b8933decfb47fc02481959ab0c65.tar.gz
Initial commit
An extremely miniamal shell. It is capable of forking processes, and passing arguments to them, but that's pretty much it.
Notes
Notes: This is pretty much a prototype, to see how easily something like a shell could be implemented in Rust.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml14
1 files changed, 14 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..e7d40d3
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,14 @@
+[package]
+name = "dwarvish"
+version = "0.0.0"
+edition = "2021"
+license = "MIT"
+description = "A POSIX compliance shell and tiny functional programming language"
+
+[[bin]]
+name = "dwvsh"
+path = "src/main.rs"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]