summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRory Dudley2024-09-13 22:38:36 -0600
committerRory Dudley2024-09-13 22:38:36 -0600
commit2852f93b714cf8ea83ba7d9aa5d6b138f58ee7e6 (patch)
tree532e2e6d7e1f0f4fc93814ff9e2f876c4820de5c /Cargo.toml
parentfd245ce1561fe5a6e71c5a359436e8ead01a977d (diff)
downloaddwarvish-2852f93b714cf8ea83ba7d9aa5d6b138f58ee7e6.tar.gz
Add autocomplete
This patch adds a fairly rudimentary form of autocomplete. For starters, it only works for filepaths, not for programs. Additionally, it currently only works for the present working directory. You cannot yet autocomplete even one more level deep.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 93c090a..3aed5a3 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -14,5 +14,6 @@ path = "src/main.rs"
[dependencies]
libc = "0.2.153"
+nix = { version = "0.29.0", features = ["signal"] }
signal-hook = "0.3.17"
termios = "0.3.3"