summaryrefslogtreecommitdiffstats
path: root/Cargo.toml
diff options
context:
space:
mode:
authorRory Dudley2024-02-16 22:36:31 -0700
committerRory Dudley2024-02-16 22:36:31 -0700
commitc101a8c2abf0c25fc75e4101a83ae56bc2a9b789 (patch)
tree03bb263871842cde18221e258b006da77c3a89aa /Cargo.toml
parentf7b6c2dae63a1ada4fd097b5714d93494003ea98 (diff)
downloaddwarvish-c101a8c2abf0c25fc75e4101a83ae56bc2a9b789.tar.gz
Capture SIGINT
Added logic to capture the interrupt signal. Using a rust crate called 'ctrlc' to do the heavy lifting. Program will simply reprint the prompt on a new line if the interrup signal is detected.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml1
1 files changed, 1 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
index e7d40d3..00fdb24 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -12,3 +12,4 @@ path = "src/main.rs"
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
[dependencies]
+ctrlc = "3.4.2"